Proclaim Sync Maintenance
Incident Report for Faithlife
Resolved
The maintenance has completed.
Posted 5 months ago. Feb 06, 2018 - 09:56 PST
Identified
Proclaim Sync will be undergoing a temporary database maintenance. All other document types will continue syncing normally. You may see a red exclamation point indicating a sync failure during this maintenance window.
Posted 5 months ago. Feb 06, 2018 - 09:44 PST