Faithlife Outage
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 12, 2017 - 17:11 PDT
Investigating
Many Faithlife sites and services are currently down or experiencing degraded performance. We are on it and we'll keep you updated.
Posted 4 months ago. Aug 11, 2017 - 20:28 PDT