Logos 7 Launch
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 24, 2016 - 15:05 PDT
Monitoring
Logos.com is experiencing heavy load with the release of Logos 7. Call 1-888-875-9491 to speak with one of our friendly resource experts.
Posted over 1 year ago. Aug 22, 2016 - 10:36 PDT