Faithlife TV unavailable on some devices
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 7 months ago. May 22, 2017 - 22:20 PDT
Monitoring
Faithlife TV is available again on all supported devices.
Posted 7 months ago. May 22, 2017 - 13:38 PDT
Identified
Faithlife TV is currently unavailable on some devices. Video streaming is still available on faithlifetv.com.
Posted 7 months ago. May 22, 2017 - 13:30 PDT