Toll Free Number - Calls not completing
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 13, 2016 - 08:12 PDT
Monitoring
Our toll free line is now completing calls as expected, however, our carrier is unsure of the cause of the issue. We will continue monitoring call volume and error rates on this line.
Posted over 1 year ago. Jun 07, 2016 - 14:43 PDT
Investigating
We are currently experiencing a problem with our toll free number and are working with our carrier to identify the issue. If you are not able to complete a call to Faithlife, please email customerservice@faithlife.com, or call our local number at 360-527-1700.
Posted over 1 year ago. Jun 07, 2016 - 14:41 PDT