Elevated Errors

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Jan 04, 2026 - 10:06 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 04, 2026 - 09:24 PST

Monitoring

The systems have been stabilized and we are monitoring the results.
Posted Jan 04, 2026 - 09:21 PST

Investigating

We're experiencing an elevated level of errors for multiple services and are currently looking into the issue.
Posted Jan 04, 2026 - 09:16 PST
This incident affected: Logos Bible Software/Verbum (Logos.com, Verbum.com, App.logos.com).