Some academic and enterprise services are degraded or unavailable.

Incident Report for Faithlife

Resolved

We've found the root cause and resolved the issue. Users should no longer see errors on the LTI dashboard. All background process that previously failed have been rerun.
Posted Aug 05, 2025 - 08:41 PDT

Investigating

We are currently investigating this issue. Some academic and enterprise services may be unavailable during this time.
Posted Aug 05, 2025 - 07:30 PDT
This incident affected: Logos Bible Software/Verbum (Learning Tools Integration).