Partial Faithlife App Outage
Incident Report for Faithlife
Resolved
All issues for the "Faithlife" app have been resolved.
Posted Dec 11, 2019 - 13:59 PST
Identified
We are currently experiencing an outage in some parts of the "Faithlife" app, and are working on a resolution. Only the "Faithlife" app is impacted.
Posted Dec 11, 2019 - 13:51 PST
This incident affected: Mobile Apps.