Logos Sermons is experiencing performance issues

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 00:32 PDT

Update

The issue has been resolved.
Posted Mar 16, 2025 - 00:31 PDT

Investigating

Logos Sermons is experiencing degraded performance. Features that rely on Logos Sermons, such as the SoundFaith guide section in Logos Bible Software, may also experience degraded performance or errors. We are investigating the issue.
Posted Mar 15, 2025 - 22:23 PDT
This incident affected: Logos Sermons.