Faithlife.com Web and App Newsfeed Problems
Incident Report for Faithlife
Resolved
Issues impacting the Faithlife.com and Faithlife App newsfeed have been resolved.
Posted Dec 12, 2019 - 10:58 PST
Investigating
We are investigating an issue preventing newsfeed items from showing up on Faithlife.com and the Faithlife app. Activity feed information may be out of date.
Posted Dec 12, 2019 - 10:54 PST
This incident affected: Faithlife.com (Faithlife.com) and Mobile Apps.