Sync services unavailable
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 16:31 PDT
Investigating
Some sync services are currently offline. Data made to affected document kinds will be saved locally, but not synced to our servers or between computers.
Posted Sep 25, 2020 - 16:20 PDT
This incident affected: Logos Bible Software/Verbum (Sync).