Documents Sync Services Performance Issues
Incident Report for Faithlife
Resolved
We have resolved all performance issues with Documents Sync and documents.logos.com. We appreciate your patience!
Posted Jul 15, 2020 - 15:17 PDT
Investigating
We are currently investigating issues with some Documents sync services, as well as documents.logos.com
Posted Jul 15, 2020 - 13:50 PDT
This incident affected: Logos Bible Software/Verbum (Sync).