Connectivity issues for Android devices
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 12:33 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2021 - 12:32 PDT
Investigating
A root certificate used to sign Faithlife's SSL certificates expired on September 30th. (For technical details, see https://scotthelme.co.uk/lets-encrypt-old-root-expiration/.) Faithlife's SSL certificates are all signed with a new, valid root CA, but the presence of the old CA is causing some devices (primarily Android, but also older macOS) to fail to connect to Faithlife servers.

This impacts:

* Logos Bible Software (Android) - Sync
* Bible Engagement Project app (Android) - Sync
* Proclaim Remote (Android) - All functionality
* Proclaim (macOS <= 10.11) - Sync
Posted Oct 01, 2021 - 11:27 PDT
This incident affected: Proclaim (Proclaim API, Proclaim Sync API) and Logos Bible Software/Verbum (Sync).