Logos.com performance issues
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted 18 days ago. Aug 30, 2019 - 08:13 PDT
Update
We are continuing to investigate this issue.
Posted 18 days ago. Aug 30, 2019 - 08:13 PDT
Investigating
Logos.com and Faithlife Sites are experiencing degraded performance.
Posted 19 days ago. Aug 29, 2019 - 15:42 PDT
This incident affected: Faithlife Sites (Products API, Logos.com, Sites Platform) and Logos Bible Software (Licenses API).