sermons.logos.com experiencing degraded performance and sometimes fails to load

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 13:10 PDT

Investigating

We are investigating this issue.
Posted Apr 20, 2026 - 09:27 PDT
This incident affected: Logos Sermons.