Faithlife Sites Running Slowly
Incident Report for Faithlife
Resolved
Performance issues for Faithlife Sites have been resolved.
Posted 19 days ago. Aug 01, 2019 - 13:59 PDT
Investigating
Faithlife Sites are currently running slowly; we are investigating the issue.
Posted 19 days ago. Aug 01, 2019 - 11:10 PDT
This incident affected: Faithlife Sites (Sites Platform).