Proclaim Song and Song Arrangement data are experiencing sync issues

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 10:48 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 13, 2025 - 10:29 PDT

Monitoring

A fix has been implemented and we are monitoring performance.
Posted Apr 13, 2025 - 10:28 PDT

Update

A DB Ugrade caused unexpected downtime across several Proclaim and Sermon services.
Posted Apr 13, 2025 - 09:54 PDT

Identified

Proclaim Presentations are still syncing, the sync error only impacts song and song arrangement data.
The issue has been identified and we are working on the solution.
Posted Apr 13, 2025 - 09:10 PDT

Investigating

We are currently investigating this issue. Sync is failing for some users.
Posted Apr 13, 2025 - 08:17 PDT
This incident affected: Proclaim (Proclaim Sync API) and Logos Sermons.