Some services are experiencing difficulties
Incident Report for Faithlife
Resolved
The incident has been addressed and resolved. All services should be operational. Thank you for your patience.
Posted Jul 18, 2024 - 07:00 PDT
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 06:43 PDT
Investigating
Some services are experiencing errors trying to access internal resources. We are actively investigating the issue. At this time, some functionality at app.logos.com will be unavailable.
Posted Jul 18, 2024 - 05:24 PDT
This incident affected: Logos Bible Software/Verbum (App.logos.com, Learning Tools Integration, Resources API).