Product search and access is slow/failing

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Jun 05, 2023 - 10:29 PDT

Update

All systems are back to normal. Thank you for your patience!
Posted Jun 05, 2023 - 10:29 PDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2023 - 09:52 PDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2023 - 09:32 PDT

Update

We are temporarily and briefly taking some application capabilities offline in order to put in a better fix. Should be back online in a few minutes.
Posted Jun 05, 2023 - 09:32 PDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2023 - 07:59 PDT

Update

We've found the root cause and added workarounds for the underlying issue. All applications and websites should now be operational, although several will have degraded performance until the underlying issue is fixed.
Posted Jun 05, 2023 - 07:17 PDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2023 - 07:00 PDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2023 - 06:46 PDT

Investigating

We are currently investigating this issue.
Posted Jun 05, 2023 - 06:07 PDT
This incident affected: Faithlife.com (Faithlife.com), Logos Bible Software/Verbum (Logos.com, Verbum.com, App.logos.com, Learning Tools Integration, Resources API), and Core Services (Licenses API).