Multiple site outages
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Oct 30, 2022 - 18:20 PDT
Investigating
We are currently investigating this issue.
Posted Oct 30, 2022 - 15:25 PDT
This incident affected: Proclaim (Digital Signage) and Faithlife Sermons, Faithlife TV.