Faithlife websites and services inaccessible from some ISPs
Incident Report for Faithlife
Resolved
Our ISP reports that the issue has been resolved.
Posted Jun 03, 2022 - 07:02 PDT
Monitoring
Update from our ISP: "We have started seeing traffic shift back to our transit peer that we were having issues with. The issue appears to be resolving."
Posted Jun 01, 2022 - 15:29 PDT
Update
We have an update from our ISP: "our Core Network Engineers are working with Google to restore this outage."
Posted Jun 01, 2022 - 11:53 PDT
Identified
There is an Internet routing outage between our ISP (Wave) and Google, affecting multiple residential ISPs. We don't have any further details at this time.
Posted Jun 01, 2022 - 10:21 PDT
Investigating
We are currently investigating this issue to determine the root of the issue.
Posted Jun 01, 2022 - 09:43 PDT
This incident affected: Faithlife.com (Faithlife.com) and Logos Bible Software/Verbum (Logos.com).