app.logos.com degraded performance in Chrome for Mac v131
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 08:26 PST
Update
Chrome version 132 and above resolves this issue. Please upgrade to the latest Chrome version if you are having trouble accessing drop down menus in app.logos.com.
Posted Jan 22, 2025 - 08:26 PST
Monitoring
Potential crash in Chrome for Mac version 131 when interacting with some drop down menus. Google has fixed the issue in version 132. Users who are affected should update their version of Chrome for Mac to version 132 or above.
Posted Jan 14, 2025 - 16:58 PST
This incident affected: Logos Bible Software/Verbum (App.logos.com).