E-Commerce Sites are Down Due to Maintenance

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Jul 14, 2023 - 08:48 PDT

Identified

A standard database maintenance procedure is taking longer than expected.
Posted Jul 14, 2023 - 07:52 PDT
This incident affected: Logos Bible Software/Verbum (Logos.com, Verbum.com).