Logos.com is down
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jul 01, 2019 - 12:42 PDT
Monitoring
We have resolved the issue affecting a number of our sites, but we will continue to monitor the situation.
Posted Jul 01, 2019 - 12:01 PDT
Update
We are continuing to investigate this issue.
Posted Jul 01, 2019 - 11:02 PDT
Update
We are continuing to investigate this issue.
Posted Jul 01, 2019 - 10:49 PDT
Update
The Faithlife Sites Platform is also affected by this outage.
Posted Jul 01, 2019 - 10:43 PDT
Investigating
Logos.com is currently down. Our team is actively investigating the issue.
Posted Jul 01, 2019 - 10:38 PDT
This incident affected: Faithlife Sites (Logos.com, Sites Platform, Verbum.com) and Faithlife Ebooks.