Issue impacting orders and product searching
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jan 19, 2019 - 04:38 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 19, 2019 - 04:16 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 19, 2019 - 03:33 PST
This incident affected: Faithlife Sites (Products API, Logos.com, Sites Platform).