Faithlife.com is currently down

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Feb 24, 2023 - 05:46 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2023 - 05:32 PST

Update

We are continuing to investigate this issue.
Posted Feb 24, 2023 - 05:05 PST

Update

We are continuing to investigate this issue.
Posted Feb 24, 2023 - 05:04 PST

Investigating

Faithlife.com is currently down and we are actively investigating this issue.
Posted Feb 24, 2023 - 04:55 PST
This incident affected: Proclaim (Proclaim API, Proclaim Slide Renderer, Proclaim Sync API, Digital Signage), Faithlife.com (Faithlife.com), Logos Bible Software/Verbum (Logos.com, App.logos.com, Learning Tools Integration), and Logos Sermons.