Orders API service disruption
Incident Report for Faithlife
Resolved
Free Book of the Month increased load overloaded our backend OrdersAPI, which was already under above average load from Logos 9 launch.

We have throttled Free Book of the Month traffic to avoid load conflicts with launch.
Posted Nov 02, 2020 - 12:30 PST
Investigating
We are currently investigating this issue.
Posted Nov 02, 2020 - 11:50 PST
This incident affected: Logos Bible Software/Verbum (Logos.com).