Ongoing Logos.com and Verbum.com Maintenance
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 10:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results. Logos.com and Verbum.com are working correctly now.
Posted Jul 20, 2022 - 09:20 PDT
Update
We are implementing an identified fix.
Posted Jul 20, 2022 - 06:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2022 - 04:38 PDT
Identified
The monthly scheduled maintenance for Logos.com and Verbum.com is still ongoing.
Posted Jul 20, 2022 - 04:37 PDT
This incident affected: Logos Bible Software/Verbum (Logos.com, Verbum.com).