Faithlife.com and Faithlife App Intermittently Failing to Load
Incident Report for Faithlife
Resolved
We have resolved the issues causing errors on Faithlife.com and the Faithlife App.
Posted Feb 12, 2020 - 11:47 PST
Investigating
We are investigating Faithlife.com and the Faithlife App reporting "Internal Server Error" intermittently for users.
Posted Feb 12, 2020 - 11:34 PST
This incident affected: Faithlife.com (Faithlife.com) and Mobile Apps.