Logos Bible Software Service Degradation
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 07:32 PDT
Update
As we migrate these services to increase performance, customers may experience intermittent sync errors. These should be brief and resolve themselves after a few minutes.
Posted Jul 18, 2022 - 12:25 PDT
Identified
A number of our services that back app.logos.com and Logos Bible Software are experiencing performance degradation. We are actively working on migrating these services to increase performance. We expect this to be resolved Tuesday with our monthly maintenance.
Posted Jul 15, 2022 - 15:56 PDT
This incident affected: Logos Bible Software/Verbum (App.logos.com, Sync).