Degraded performance on Faithlife Giving
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jan 29, 2022 - 12:01 PST
Investigating
We are currently investigating poor performance and 504s on Faithlife Giving. We will keep this page updated as we learn more and work to resolve the issue.
Posted Jan 29, 2022 - 11:48 PST
This incident affected: Faithlife Giving.