Logos Community partial network outage
Incident Report for Faithlife
Resolved
Logos Community is now fully operational.
Posted Dec 19, 2024 - 03:37 PST
Identified
We have identified a problem with a vendor that prevents access to part of our Logos Community site from certain regions.
Posted Dec 18, 2024 - 14:32 PST
This incident affected: Logos Community.