Payment Processor Outage
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 09:59 PDT
Update
We are able to process payments and create billing profiles, we’ll continue to monitor.
Posted Nov 01, 2022 - 08:08 PDT
Monitoring
We're awaiting a resolution from our payment processor.
Posted Nov 01, 2022 - 00:45 PDT
Investigating
We are currently unable to process payments or create billing profiles due to an outage with our payment processor.
Posted Nov 01, 2022 - 00:44 PDT
This incident affected: Faithlife.com (Faithlife.com), Logos Bible Software/Verbum (Logos.com, Verbum.com), and Faithlife Giving.