Service Outage
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 11:02 PST
Update
All affected services seem to be operational. Continuing to monitor the situation.
Posted Nov 16, 2021 - 10:23 PST
Monitoring
Posted Nov 16, 2021 - 10:13 PST
Identified
We have identified an issue with Google Cloud that our services depend on.
Posted Nov 16, 2021 - 10:01 PST
Investigating
We are currently investigating this issue.
Posted Nov 16, 2021 - 09:55 PST
This incident affected: Faithlife.com (Faithlife.com), Proclaim (Digital Signage), and Faithlife Sermons, Faithlife TV.