Community Forums unavailable
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Dec 11, 2020 - 07:42 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2020 - 07:34 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 11, 2020 - 06:53 PST