Unable to edit sites in Church Sites Editor
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Nov 30, 2021 - 15:06 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 30, 2021 - 14:49 PST
Investigating
We are currently investigating this issue.
Posted Nov 30, 2021 - 14:30 PST
This incident affected: Faithlife Sites (Faithlife Sites).