Degraded payment processing performance
Incident Report for Faithlife
Resolved
The issue with our downstream payment processor has been resolved.
Posted Feb 02, 2023 - 17:10 PST
Identified
We have identified the issue as a connectivity problem with our downstream payment processing services.
Posted Feb 02, 2023 - 14:19 PST
Investigating
We are currently investigating delayed order payment processing. We will keep this page updated as we learn more and work to resolve the issue.
Posted Feb 02, 2023 - 14:14 PST
This incident affected: Faithlife.com (Faithlife.com), Logos Bible Software/Verbum (Logos.com, Verbum.com), and Faithlife Ebooks.