Image uploads on Faithlife.com
Incident Report for Faithlife
Resolved
This issue has been resolved. Thank you for your patience.
Posted Apr 02, 2020 - 14:03 PDT
Identified
We have identified an issue causing images to fail to upload on Faithlife.com, and are working on implementing a fix.
Posted Apr 02, 2020 - 12:09 PDT
This incident affected: Files (Amber.Faithlife.com) and Faithlife.com (Faithlife.com).