Faithlife Sites Stability and Edit Issues
Incident Report for Faithlife
Resolved
Issues impacting Faithlife sites have been resolved.
Posted Sep 30, 2019 - 16:25 PDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2019 - 16:25 PDT
Investigating
We are investigating stability issues with Faithlife Sites, and site editing is currently unavailable. Some additional sites are also unavailable, however, Logos.com is functioning as expected at this time.
Posted Sep 30, 2019 - 11:12 PDT
This incident affected: Faithlife Sites (Sites Platform, Verbum.com) and Faithlife Ebooks.