Logos for iOS/Android stuck loading library data

Incident Report for Faithlife

Resolved

This incident has been resolved.
Posted Oct 20, 2022 - 12:57 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2022 - 12:29 PDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2022 - 11:21 PDT