Unable to Load Church Sites

Incident Report for Faithlife

Resolved

We have identified the issued and deployed a fix. We will continue to monitor but as of now church sites will load and continue to operate as normal.
Posted Feb 22, 2023 - 13:54 PST

Investigating

We are currently investigating this issue.
Posted Feb 22, 2023 - 13:45 PST