Faithlife Sites Admin Service Disruption
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 12:04 PDT
Identified
An issue encountered in deployment is preventing access to admin.faithlifesites.com. We are continuing to investigate.
Posted Apr 26, 2021 - 11:28 PDT
This incident affected: Faithlife Sites (Sites Platform).