Logos.com is currently down

Incident Report for Faithlife

Resolved

We have identified the issue and have restored service.
Posted Dec 26, 2024 - 10:24 PST

Identified

An update was causing the site to be unresponsive.
Posted Dec 26, 2024 - 10:18 PST

Investigating

Logos.com is currently down and we are actively investigating this issue.
Posted Dec 26, 2024 - 09:26 PST
This incident affected: Logos Bible Software/Verbum (Logos.com, Verbum.com) and Lexhampress.com.