Worldpay performance
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 06:39 PST
Investigating
We are currently monitoring degraded performance while purchasing via our commerce sites.
Posted Dec 03, 2019 - 20:50 PST
This incident affected: Faithlife Sites (Logos.com).