Faithlife.com and Proclaim Slowness
Incident Report for Faithlife
Resolved
Performance issues with Faithlife sites and services have been resolved.
Posted Mar 22, 2020 - 11:48 PDT
Update
We are continuing to investigate slowness and unresponsiveness with Faithlife.com, Faithlife Giving, and Proclaim. We may have identified the root cause, and are implementing some immediate measures to improve responsiveness while we investigate a long-term fix.
Posted Mar 22, 2020 - 08:55 PDT
Investigating
We are investigating slowness and intermittent unresponsiveness on Faithlife.com
Posted Mar 22, 2020 - 08:23 PDT
This incident affected: Proclaim (Proclaim API, Proclaim Sync API) and Faithlife.com (Faithlife.com).