Proclaim Digital Signage and Proclaim Remote not loading for some users

Incident Report for Faithlife

Resolved

This incident has been resolved
Posted May 25, 2025 - 10:56 PDT

Investigating

We are investigating this issue and have shipped a potential fix.
Posted May 25, 2025 - 10:44 PDT
This incident affected: Proclaim (Proclaim Slide Renderer, Digital Signage).