E-Commerce Sites Currently Down
Incident Report for Faithlife
Resolved
We have resolved a configuration issue that was causing product pages to fail to load for roughly 5 to 6 minutes for customers. We apologize for any inconvenience or confusion while attempting to access products.
Posted Oct 20, 2020 - 11:41 PDT
Investigating
We are investigating inaccessibility of Logos.com and other sales sites.
Posted Oct 20, 2020 - 11:35 PDT
This incident affected: Logos Bible Software/Verbum (Logos.com, Verbum.com).