Slow load times/partial crashes in the site editor
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 09:56 PDT
Monitoring
We are monitoring the situation but performance on the site editor is executing at a stable level. Will be monitoring tonight during our patch update at 7 pm PT. We expect a full resolution by tomorrow morning after our patch update. As of now, you should be able to edit your site as expected with very minimal delays.
Posted Jul 19, 2022 - 10:21 PDT
Update
We are continuing to work on a fix for this issue. The temporary workaround is to try again if you are presented with a timeout error or redirected to our products page, it may take a few attempts. We should have a more prominent solution early next week as we are shipping some major improvements Tuesday evening ~ around 7 PM PT.

We apologize for any inconvenience during this time.
Posted Jul 15, 2022 - 10:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 14, 2022 - 08:55 PDT
Update
Made some improvements by migrating our database and a couple of underlying APIs.
Further improvements and performance testing still needs to happen. A change to our DNS will go out later today that should improve some performance.
Posted Jul 13, 2022 - 09:47 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 13, 2022 - 09:43 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 11, 2022 - 10:10 PDT
Identified
We've noticed our Site Editor is performing slower and planning on migrating our API to a new location to increase performance.
Posted Jul 11, 2022 - 10:10 PDT
This incident affected: Faithlife Sites (Faithlife Sites).