Degraded performance on Faithlife websites
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 18:56 PDT
Update
We are continuing to investigate issues causing poor performance on our sites so that we can implement a fix. We appreciate your patience, and will continue to update this status site as we learn more.
Posted Apr 01, 2020 - 14:59 PDT
Investigating
We are currently investigating poor performance and 504s on Faithlife.com, Logos.com, and Faithlife TV. We will keep this page updated as we learn more and work to resolve the issue.
Posted Apr 01, 2020 - 12:16 PDT
This incident affected: Faithlife TV (Faithlife TV), Faithlife.com (Faithlife.com), Faithlife Sites (Products API, Logos.com), and Mobile Apps.