Multiple websites and services slow or down
Incident Report for Faithlife
Resolved
This incident has been resolved.
Posted Jul 16, 2022 - 04:24 PDT
Monitoring
The communication issues have been resolved. We are monitoring the connection.
Posted Jul 16, 2022 - 04:01 PDT
Investigating
There are unknown issues communicating within our websites and services. We are currently investigating the issue. It is unclear exactly what all is affected right now.
Posted Jul 16, 2022 - 03:19 PDT
This incident affected: Logos Bible Software/Verbum (Logos.com, Sign In), Faithlife.com (Faithlife.com, Community API), Core Services (Licenses API), and Faithlife Giving.